System Requirements

MapGuide Viewer

MapGuide Open Source offers two viewer technologies: A DWF™-based viewer and an AJAX-based viewer.

  • The Autodesk DWF Viewer supports Windows 98 SE, Windows 2000 (SP2), Windows XP Professional and Home Edition, and Internet Explorer 5.01 and later.
  • The AJAX Viewer uses DHTML to present maps and spatial data in the browser. It does not require a plug-in and supports most browsers, including Microsoft Internet Explorer 6+, Firefox™, Chrome and Safari.

MapGuide Server and Web Server Extensions

  • Linux: CentOS 5.6 or Ubuntu 12.04. Other distributions unsupported and/or un-tested
  • Windows XP/2003/Vista/7/2008/2008R2. Server-versions of windows recommended for production installations

Web Servers

  • Apache HTTP Server 2.2.21
  • Microsoft IIS 5.1 on Windows XP
  • Microsoft IIS 6.0 on Windows Server 2003
  • Microsoft IIS 7.0 on Windows Vista
  • Microsoft IIS 7.5 on Windows 7 / Windows Server 2008

Application Development

  • PHP 5.3.8
  • .NET Framework 4.0 (optional)
  • Java™ JDK 6.0 and the Tomcat Servlet engine version 7.0.23 (optional)